Desktop Search

OASIS Validation Utility Tool (VUT) v1.3.0

Release Notes

The Validation Utility Tool (VUT) is a software utility that can be used to validate OASIS submission files in XML format. The tool enforces the edits that are mapped to the OASIS items, as published in the OASIS-C, OASIS-C1 and OASIS-C2 Data Specifications. The initial release of the VUT incorporated the OASIS-C v2.10.1 Data Specifications and OASIS-C1 v2.11.2 Data Specifications, as well as the Errata identified for these specifications. The second release addressed the issues identified in the latest Errata, as well as two bug fixes: (1) The ICD-9 lookup was not correctly finding three-digit ICD-9 codes; (2) The VUT was not handling the situation where multiple edits impact the same target variable - specifically, the MEDICARE_NUM and MEDICAID_NUM items. These bugs have been fixed. The third release incorporated the OASIS-C1 v2.12.0 Data Specifications. The fourth release addressed issues 10 through 14 from the Errata for v2.12.0; these issues were added after the previous VUT release. The sixth release, v1.2.0, added support for the OASIS C2 v2.20.1 Data Specifications which were effective January 1, 2017. The seventh release, v1.2.1 fixed a bug in the implementation of edit -5460 for checking assessments in 2017. The eighth release, v1.3.0, adds support for the v2.21.0 OASIS Data Submission Specifications and associated Errata while continuing to support the versions previously mentioned for older assessments.

Please note that there are edits that the VUT cannot support because they are edits against existing ASAP system data. The VUT does not interface with ASAP therefore it cannot confirm those edits. The VUT does not currently interface with the OASIS HH PPS grouper therefore it does not recalculate and confirm that HIPPS values are correct.

Last Modified on 8/15/2018